JP1 Remotes Forum Index JP1 Remotes


FAQFAQ SearchSearch 7 days of topics7 Days MemberlistMemberlist UsergroupsUsergroups RegisterRegister
ProfileProfile Log in to check your private messagesLog in to check your private messages Log inLog in

sharp an-ip100 remote
Goto page Previous  1, 2, 3
 
Post new topic   Reply to topic    JP1 Remotes Forum Index -> Slingbox
View previous topic :: View next topic  
Author Message
chuliu



Joined: 04 Dec 2010
Posts: 388
Location: Hong Kong

PostPosted: Sat Jan 23, 2016 11:44 am    Post subject: Reply with quote

chuliu wrote:
Hello,
I compared numeric buttons 1 to 5 on Kaseikyo, changed sharpdvd, and my manual protocol.
Kaseikyo and changed sharpdvd appeared the same.
My manual protocol differes from Kaseikyo and sharpdvd in that :
1. the byte before the lead out (one on,LO) in Kaseikyo is always
(437 -1307) but that byte is always (437,-437) in my manual protocol.

2. the lead out in Kaseikyo and sharpdvd is -75000 and in my manual protocol it is -70000.

I assume something wrong with the check nibble calculation.


I have a correction: Not all signal in my excel workbook shows (437,-437) in the byte before LO. I can only say that they differ. The LO of Kaesiekyo is for sure to be -75000, though.
All the other bytes of numeric 1-5 are the same. Just the byte before LO differs. However, I need to make a more complete check on the three signals.

I will make more comparison later.

Thanks.
Back to top
View user's profile Send private message
3FG
Expert


Joined: 19 May 2009
Posts: 3256

PostPosted: Sat Jan 23, 2016 6:13 pm    Post subject: Reply with quote

chuliu,
I see what you mean. It looks like the SharpDVDtranslator doesn't calculate checksums correctly for some combinations of device and subdevice. I'll work on fixing that. There's no need for you to spend more time on this right now.
Back to top
View user's profile Send private message
3FG
Expert


Joined: 19 May 2009
Posts: 3256

PostPosted: Sat Jan 23, 2016 11:04 pm    Post subject: Reply with quote

I've updated the SharpDVDTranslator. I expected to find a coding error in calculating the XORs, but in fact the code was obviously written before we had much understanding of the checksums used in Kaseikyo type protocols. The existing code didn't perform XORs at all.

chului, if you want to test the new Translator, I've uploaded the class file. To use it, use 7Zip or Winzip to open RemoteMaster.jar (note that a jar file is actually just a zip file), and drill down through com\hifiremote\jp1\translate\. Drag the new SharpDVDTranslator.class into 7Zip (or Winzip), and then close 7Zip. A simple verification would be to make a short SharpDVD upgrade with device 8.26 and to enter an OBC of 2. The Hex data should then be BF 7F, and not BF 7E. (Your 01FF executor needs the binary complement -- 40 80 -- for its hex bytes, because it defined 0 and 1 the opposite way to UEI.)
Back to top
View user's profile Send private message
chuliu



Joined: 04 Dec 2010
Posts: 388
Location: Hong Kong

PostPosted: Sun Jan 24, 2016 12:55 am    Post subject: Reply with quote

Thanks. I tested with my c2 and ir widget and it seems that all bytes are the same except the LO in my file is -70 and in Sharpdvd is -75.

I tried to change protocols.ini to make the LO option 65, but the LO remains the same.
Back to top
View user's profile Send private message
The Robman
Site Owner


Joined: 01 Aug 2003
Posts: 19080
Location: Chicago, IL

PostPosted: Sun Jan 24, 2016 1:00 am    Post subject: Reply with quote

chuliu wrote:
Thanks. I tested with my c2 and ir widget and it seems that all bytes are the same except the LO in my file is -70 and in Sharpdvd is -75.

I tried to change protocols.ini to make the LO option 65, but the LO remains the same.

The three LO options are hard coded into the executor itself, we just pass an indicator to the executor telling it which one to use. I suspect that the LO produced by the executor will work as -70 and -75 are probably close enough.
_________________
Rob
www.hifi-remote.com
Please don't PM me with remote questions, post them in the forums so all the experts can help!
Back to top
View user's profile Send private message Visit poster's website
chuliu



Joined: 04 Dec 2010
Posts: 388
Location: Hong Kong

PostPosted: Sun Jan 24, 2016 5:00 am    Post subject: Reply with quote

Thanks. I asked friend to test on his sharp an-ip100 and all were good. Thanks so much.
Back to top
View user's profile Send private message
chuliu



Joined: 04 Dec 2010
Posts: 388
Location: Hong Kong

PostPosted: Thu Apr 04, 2019 8:20 am    Post subject: Reply with quote

Hi, all.
I read on the other thread titled "Sharp Bluray player BD-HP25X" that an issue with sharp dvd protocol was fixed. The device and subdevice for that device is 8,48, which is the same as sharp dv-hrd30, or dv-hrd300, which I started another thread for. I compared the signal from original remote and the upgrade that the user at "Sharp Bluray player BD-HP25X" uploaded which he said worked. The result is indeed indentical as I check the command part in irscope. The power button both has {A=$555AF10C828F} in irscope.

So I went on to create an upgrade with protocols.ini modifed with the values that Rob suggested in the "Sharp Bluray player BD-HP25X" thread, with device and subdevice 8,26. I then captured the signal and compared it with the original remote of a sharp an-ip100, which is of course (8,26). It is different!
Here it is

The first one is power button from a original remote and the second from an upgrade. I hope someone can fix the sharp dvd protocol in its entirety. Thanks.
Back to top
View user's profile Send private message
The Robman
Site Owner


Joined: 01 Aug 2003
Posts: 19080
Location: Chicago, IL

PostPosted: Thu Apr 04, 2019 4:55 pm    Post subject: Reply with quote

Hi chuliu,
I have updated the syntax now so that it should hopefully work for this device also. I have updated the bin files here:

http://www.hifi-remote.com/forums/dload.php?action=file&file_id=12306
_________________
Rob
www.hifi-remote.com
Please don't PM me with remote questions, post them in the forums so all the experts can help!
Back to top
View user's profile Send private message Visit poster's website
chuliu



Joined: 04 Dec 2010
Posts: 388
Location: Hong Kong

PostPosted: Fri Apr 05, 2019 11:16 am    Post subject: Reply with quote

HI, Rob. The bin file appears to work.
Is the syntax that you updated the same as that in the sharp bd player thread? Because I also made the same change to protocols.ini but the resulting bin didn't work. Thanks.
Back to top
View user's profile Send private message
chuliu



Joined: 04 Dec 2010
Posts: 388
Location: Hong Kong

PostPosted: Fri Apr 05, 2019 11:30 am    Post subject: Reply with quote

I just read in other threads that Rob has updated the change made to protocols.ini. Thanks.
Back to top
View user's profile Send private message
The Robman
Site Owner


Joined: 01 Aug 2003
Posts: 19080
Location: Chicago, IL

PostPosted: Fri Apr 05, 2019 1:38 pm    Post subject: Reply with quote

Yeah, the new syntax change is listed here:
http://www.hifi-remote.com/forums/viewtopic.php?t=101742
_________________
Rob
www.hifi-remote.com
Please don't PM me with remote questions, post them in the forums so all the experts can help!
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic       JP1 Remotes Forum Index -> Slingbox All times are GMT - 5 Hours
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

Powered by phpBB © 2001, 2005 phpBB Group
Get Smart! the band's official homepage Rockabilly Central