JP1 Remotes Forum Index JP1 Remotes


FAQFAQ SearchSearch 7 days of topics7 Days MemberlistMemberlist UsergroupsUsergroups RegisterRegister
ProfileProfile Log in to check your private messagesLog in to check your private messages Log inLog in

JP1.3 cable not recognized

 
Post new topic   Reply to topic    JP1 Remotes Forum Index -> JP1 - Hardware
View previous topic :: View next topic  
Author Message
ckeays



Joined: 12 Jan 2015
Posts: 27

PostPosted: Fri Jan 23, 2015 10:20 am    Post subject: JP1.3 cable not recognized Reply with quote

Hi guys,

I built a JP1.3 cable from a USBtoTTL converter (A CP2102 module).

These modules work great for other projects, and I use them all the time. I am 100% certain it's not a driver issue.

Problem:

I test the cable with jp1xtest.exe and all is good. It doesn't work in ir.exe.
Code:
D:\JP1 Remote\TestGroup>jp1xtest
jp1xtest version 0.00


*** FOUND A JP1.2/3 COMPATIBLE REMOTE ON COM2! ***
Signature is 31793179
Memory address is $0600
Memory size is $1400 (5120)

D:\JP1 Remote\TestGroup>pause
Press any key to continue . . .


I even logged the serial communication which clearly shows TX and RX are working. I know the RTS line is connected to the reset pin on the remote because the lights flash when the remote resets in jp1xtest.exe and in ir.exe!

here is a log from the serial communications:
Code:
Port opened by process "jp1xtest.exe" (PID: 1660)

Request: 01/23/2015 10:03:40 AM.468750064

45 45 45 EEE

Answer: 01/23/2015 10:03:41 AM.375000064 (+0.0000000000 seconds)

06 .

Request: 01/23/2015 10:03:41 AM.375000064 (+0.0000000000 seconds)

56 V

Answer: 01/23/2015 10:03:41 AM.437500064 (+0.0625000000 seconds)

28 06 00 33 31 37 39 33 31 37 39 2E (..31793179.

Port closed


So this shows everything is working great, HOWEVER it does not work in IR.exe.

Any advice? The USB to TTL converter represents the port as a regular serial port on com2, so I know it is working.

I have a home built serial port programmer that is working good but I wanted to use a USB cable so I could use my laptop.
I am using windows XP 32 bit, SP3.

Here is a log from ir801.exe:
Code:
Port opened by process "ir.exe" (PID: 3352)

Request: 01/23/2015 10:21:06 AM.437500064

 45 45 45 45                                       EEEE           

Port closed


As you can see it resets okay, transmits okay, but does not receive. I know my hardware is wired correctly (why would it work with jp1xtest.exe?) I even tried to short RXD and TXD on the CP2102 module and it works in hyper terminal (whatever I type in is echoed back to the terminal)

Any help or troubleshooting advice is greatly appreciated, I'm stumped.
Back to top
View user's profile Send private message
mdavej
Expert


Joined: 08 Oct 2003
Posts: 3716

PostPosted: Fri Jan 23, 2015 10:51 am    Post subject: Reply with quote

Why are you still using IR instead of RMIR? Development stopped on IR years ago. Give RMIR a try, then post back if you still have issues.
Back to top
View user's profile Send private message
vickyg2003
Site Admin


Joined: 20 Mar 2004
Posts: 6953
Location: Florida

PostPosted: Fri Jan 23, 2015 12:03 pm    Post subject: Reply with quote

Do you have the correct interface selected from the menu?
_________________
Remember to provide feedback to let us know how the problem was solved and share your upgrades.

Tip: When creating an upgrade, always include ALL functions from the oem remote, even if you never plan on assigning them to a button. Complete function lists makes an upgrade more helpful to others.
Back to top
View user's profile Send private message Visit poster's website
ckeays



Joined: 12 Jan 2015
Posts: 27

PostPosted: Fri Jan 23, 2015 7:59 pm    Post subject: Reply with quote

vickyg2003 wrote:
Do you have the correct interface selected from the menu?


yes I have selected the correct interface.
Back to top
View user's profile Send private message
ckeays



Joined: 12 Jan 2015
Posts: 27

PostPosted: Fri Jan 23, 2015 8:22 pm    Post subject: Reply with quote

mdavej wrote:
Why are you still using IR instead of RMIR? Development stopped on IR years ago. Give RMIR a try, then post back if you still have issues.


tried it, also does not work.
Back to top
View user's profile Send private message
3FG
Expert


Joined: 19 May 2009
Posts: 3240

PostPosted: Fri Jan 23, 2015 11:47 pm    Post subject: Reply with quote

The issue is the 2102 chipset. It won't work with our tools (RMIR or IR) for JP1.3 and earlier serial remotes. It's possible that the problem is actually in the drivers, but the Linux folks gave up trying to get the Break function to work, even with considerable effort in trying to adapt the drivers.

See the last post in the linked thread for a graphic description of the problem.
Back to top
View user's profile Send private message
ckeays



Joined: 12 Jan 2015
Posts: 27

PostPosted: Sat Jan 24, 2015 7:46 am    Post subject: Reply with quote

3FG wrote:
The issue is the 2102 chipset. It won't work with our tools (RMIR or IR) for JP1.3 and earlier serial remotes. It's possible that the problem is actually in the drivers, but the Linux folks gave up trying to get the Break function to work, even with considerable effort in trying to adapt the drivers.

See the last post in the linked thread for a graphic description of the problem.


Best answer, thank you!

I suspected the software was at fault because it worked with the test program.

I guess I will give up on trying to make it work.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic       JP1 Remotes Forum Index -> JP1 - Hardware All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

Powered by phpBB © 2001, 2005 phpBB Group
Get Smart! the band's official homepage Rockabilly Central