JP1 Remotes Forum Index JP1 Remotes


FAQFAQ SearchSearch 7 days of topics7 Days MemberlistMemberlist UsergroupsUsergroups RegisterRegister
ProfileProfile Log in to check your private messagesLog in to check your private messages Log inLog in

X10 with URC7980 and IR7423RF

 
Post new topic   Reply to topic    JP1 Remotes Forum Index -> X10 and Home Automation
View previous topic :: View next topic  
Author Message
gna03633



Joined: 25 Jul 2005
Posts: 9

PostPosted: Thu Jan 05, 2017 5:43 pm    Post subject: X10 with URC7980 and IR7423RF Reply with quote

Previously I used a URC7562 with the X10_Hacked upgrade (via JP1) as I wanted a single button unit off etc.

Now with my new URC7980 (with a new JP1 cable) I'm trying to get something similar working:

- X10_Hacked doesn't work, processor is different so no suprise

- the in built 0167 doesn't seem to hit the spot, none of codes are recognised on the IR7423RF (it has an LED that flashes). Even the most basic all off.

- I've learnt the working signals from my old remote to the new URC7980. RMIR decodes them as expected as X10, all off as EFC 238 (same as 0167) and the others as multiple X10 i.e. EFC 143 then 110 for Unit 1 ON. For some reason the only learnt one that works is the single code all off. The multiple one are recognised by IR7423RF but they don't seem to repeat on a key press so don't work.

Why doesn't inbuilt 0167 work?
Why do the learnt learnt buttons work that have multiple codes?

Thanks in advance for any suggestions
Back to top
View user's profile Send private message
3FG
Expert


Joined: 19 May 2009
Posts: 3182

PostPosted: Sun Jan 08, 2017 11:24 pm    Post subject: Reply with quote

The 003F executor used in the TI2541 and MAXQ processors for setup code 0167 is somewhat different to the one in the S3C80/S3F80. Neither executor works correctly with the IR543 class of IR to X10 converters.
I've uploaded a RMDU file that should provide the functionality of the X10 Hacked.txt KM upgrade for the 7980 and also MAXQ processors. One difference is that the KM file seems to provide a delay in combination signals between the Unit Frame and the repeating Function frame(s). I don't have any X10 or an IR converter, so I can't test whether this upgrade file actually controls them. If necessary, I can add the delay.
Back to top
View user's profile Send private message
gna03633



Joined: 25 Jul 2005
Posts: 9

PostPosted: Tue Jan 10, 2017 5:23 pm    Post subject: Reply with quote

Hi 3FG, thanks for your help much appreciated.

I've downloaded the RMDU, allocated buttons I want, uploaded to remote and assigned to S.Bar. Unfortunately the IR7423RF didn't register any of key presses via the led. I tried Unit 1-6 ON, UNIT 1-6 OFF, ALL OFF and ALL LIGHTS OFF.

Don't think I forgotten something?

If I can help with something let us know
Cheers
Gna
Back to top
View user's profile Send private message
3FG
Expert


Joined: 19 May 2009
Posts: 3182

PostPosted: Tue Jan 10, 2017 11:14 pm    Post subject: Reply with quote

I think we need to see your RMIR file. I used a Widget to compare the signals for ALL OFF and ALL LIGHTS OFF as shot by a JP1.3 remote (using Rob's X10 Hacked.txt) and by my 7980. Both remotes are sending the same signals.
Back to top
View user's profile Send private message
gna03633



Joined: 25 Jul 2005
Posts: 9

PostPosted: Wed Jan 11, 2017 4:28 pm    Post subject: Reply with quote

I've uploaded to the diagnostics area:
http://www.hifi-remote.com/forums/dload.php?action=file&file_id=14337

This is my RMIR with the recent upgrade that I couldn't get to work. Hopefully you spot something.

Cheers
Back to top
View user's profile Send private message
3FG
Expert


Joined: 19 May 2009
Posts: 3182

PostPosted: Wed Jan 11, 2017 11:45 pm    Post subject: Reply with quote

I loaded your RMIR file into my 7980, and the Power button sends the signal we expect for All Off. That's the only X-10 "function only" button that is assigned. The rest of the buttons are assigned a function applied to a unit, and for that the remotes send first a frame containing the Unit number, and then a second frame with the function code. I less sure about those, but functions which apply to all units seemingly have to work. Can you try assigning a couple of others to e.g. Info and Fav?

BTW, I did try pressing the Activity button. With this particular setup, no S.Bar signals will be sent until S.Bar is highlighted with the Device button, because S.Bar codes aren't part of any activity.

The only other thing I can think of is to post a RMIR file with learns from your 7562, so I can compare the timing.
Back to top
View user's profile Send private message
gna03633



Joined: 25 Jul 2005
Posts: 9

PostPosted: Thu Jan 12, 2017 4:48 pm    Post subject: Reply with quote

Thanks 3FG

I assigned all light on and all light off to A and B (even though I don't use lamp modules) and I don't see them register on the X10 controllers LED.

Correct I only use the S.Bar as a device, doubt I'd ever assign to activity.

I've uploaded my RMIR for my 7980 with my learnt from my 7562:
http://www.hifi-remote.com/forums/dload.php?action=file&file_id=14338
see if that holds any answers.

Cheers
Back to top
View user's profile Send private message
3FG
Expert


Joined: 19 May 2009
Posts: 3182

PostPosted: Fri Jan 13, 2017 12:53 am    Post subject: Reply with quote

OK, thanks. I've tried to match the timing and the frequency of your learns, and have updated the RMDU file.
Back to top
View user's profile Send private message
gna03633



Joined: 25 Jul 2005
Posts: 9

PostPosted: Fri Jan 13, 2017 6:14 pm    Post subject: Reply with quote

Perfect all works as expected!!!

Thanks for your help 3FG.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic       JP1 Remotes Forum Index -> X10 and Home Automation All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

Powered by phpBB © 2001, 2005 phpBB Group
Get Smart! the band's official homepage Rockabilly Central