JP1 Remotes Forum Index JP1 Remotes


FAQFAQ SearchSearch 7 days of topics7 Days MemberlistMemberlist UsergroupsUsergroups RegisterRegister
ProfileProfile Log in to check your private messagesLog in to check your private messages Log inLog in

X10 protocol on the 10820
Goto page Previous  1, 2
 
Post new topic   Reply to topic    JP1 Remotes Forum Index -> X10 and Home Automation
View previous topic :: View next topic  
Author Message
vickyg2003
Site Admin


Joined: 20 Mar 2004
Posts: 6834
Location: Florida

PostPosted: Sat Dec 22, 2007 6:47 am    Post subject: Reply with quote

That's all Binky. I'm just echoing what Binky has posted before. Binky really knows these remotes!
Back to top
View user's profile Send private message Visit poster's website
jetskier



Joined: 09 Dec 2003
Posts: 278
Location: Minden, Nevada

PostPosted: Sat Dec 22, 2007 12:03 pm    Post subject: Reply with quote

You still deserve credit for getting the extender going.
Back to top
View user's profile Send private message
vickyg2003
Site Admin


Joined: 20 Mar 2004
Posts: 6834
Location: Florida

PostPosted: Sun Dec 23, 2007 1:21 am    Post subject: Reply with quote

Thanks. Of course Binky played a large part in that too.
Back to top
View user's profile Send private message Visit poster's website
jetskier



Joined: 09 Dec 2003
Posts: 278
Location: Minden, Nevada

PostPosted: Thu Dec 27, 2007 12:57 am    Post subject: Reply with quote

Here's the latest. The X10 Simple upgrade that Binky modified works great without Vicky's extender.

When I try to use the AUX2 device with the extender, it appears to default TV mode with VPT on AUX1. AUX1 is my VPT device for most device modes, but I have it turned off in AUX2 so I can use the dim/bright functions. The X10 upgrade is on AUX2 (CD 1167). The keymap is set to standard.

Here is the upgrade with the extender.

Here is the dummy ir file containing a few learns from the extended ir file.
Back to top
View user's profile Send private message
robsee



Joined: 11 Feb 2006
Posts: 15

PostPosted: Tue Dec 08, 2009 7:31 pm    Post subject: 10820B00 w/Extender X10 Problems Reply with quote

Hi,

I'm experiencing the issues mentioned in the previous post, and I don't see a solution for it. Here are the symptoms:
1)
I am unable to use CD 0167 or 1167 to the Aux 2 Button. If I press a button after pressing Aux 2, it seems to press one of the TV buttons

2)
I am able to assign and use CD 1167 when I assign it to the PVR button. If I then create a global macro, and assign a sequence using using PVR + numbers + channel up, or down, it generates a TV keypress

Here is my IR File http://www.hifi-remote.com/forums/dload.php?action=file&file_id=7625
Back to top
View user's profile Send private message
jetskier



Joined: 09 Dec 2003
Posts: 278
Location: Minden, Nevada

PostPosted: Tue Dec 08, 2009 7:56 pm    Post subject: Reply with quote

FWIW, I gave up on the 10820 extender.

There is obviously a problem with the extender and this upgrade. I can't tell you why.

I can tell you the unextended 10820 still works flawlessly with the X10 upgrade. I've used it a lot in the past couple weeks testing Christmas lights.
Back to top
View user's profile Send private message
robsee



Joined: 11 Feb 2006
Posts: 15

PostPosted: Tue Dec 08, 2009 8:26 pm    Post subject: Reply with quote

Unfortunately, I really need the DSM support, so dropping it isn't really an option for me.

Thanks,
-Rob
Back to top
View user's profile Send private message
vickyg2003
Site Admin


Joined: 20 Mar 2004
Posts: 6834
Location: Florida

PostPosted: Tue Dec 08, 2009 10:01 pm    Post subject: Reply with quote

My extender is flawed. I forgot all about needing to fix this.


To fix the extender, in the RAW DATA page in IR change byte ECDB from 09 to 0A and then upload to your remote. That should lift the device limit by 1 and give you back Aux2.
_________________
Remember to provide feedback to let us know how the problem was solved and share your upgrades.

Tip: When creating an upgrade, always include ALL functions from the oem remote, even if you never plan on assigning them to a button. Complete function lists makes an upgrade more helpful to others.
Back to top
View user's profile Send private message Visit poster's website
robsee



Joined: 11 Feb 2006
Posts: 15

PostPosted: Tue Dec 08, 2009 10:13 pm    Post subject: Reply with quote

Thanks, this appears to have resolved the problems with Aux2 and the x10 protocol macros
Back to top
View user's profile Send private message
robsee



Joined: 11 Feb 2006
Posts: 15

PostPosted: Sat Dec 12, 2009 9:12 am    Post subject: Reply with quote

Hi,

Unfortunately the problem with X-10 still exists even after the Aux 2 fix (it seemed to work at first.) Right now I have the 1167 device assigned to my PVR. If I select the lights to turn off and then use channel - it works (most of the time. It has locked up twice so that I couldn't even use PVR anymore until I re-uploaded.) If I program that sequence into a DSM or regular macro, one of the following things happens.
1) it works for a while and then stops
2) it doesn't generate any signal that the X10 receiver recognizes
3) it generates a single button press that the x10 receiver recognizes (even though it is a sequence of presses)

Any suggestions ?

Thanks,
-Rob
Back to top
View user's profile Send private message
vickyg2003
Site Admin


Joined: 20 Mar 2004
Posts: 6834
Location: Florida

PostPosted: Sat Dec 12, 2009 10:21 am    Post subject: Reply with quote

Quote:
1) it works for a while and then stops



That's usually a symptom of weak batteries, failing batteries or loose batteries.

If new batteries don't fix the problem, upload your IR file so someone can take a look.
_________________
Remember to provide feedback to let us know how the problem was solved and share your upgrades.

Tip: When creating an upgrade, always include ALL functions from the oem remote, even if you never plan on assigning them to a button. Complete function lists makes an upgrade more helpful to others.
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic       JP1 Remotes Forum Index -> X10 and Home Automation All times are GMT - 5 Hours
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

Powered by phpBB © 2001, 2005 phpBB Group
Get Smart! the band's official homepage Rockabilly Central